Server Infomation

Needs Staff - Arcane Wars

How do I play Needs Staff - Arcane Wars?

To play Needs Staff - Arcane Wars we recommend Minecraft Version 1.16.5. You can select different versions of Minecraft via the main menu when loading the launcher and select 1.16.5.

Vote For Needs Staff - Arcane Wars

A brief description of Needs Staff - Arcane Wars

Needs Staff 3 Helper 3 Mods 2 Admins 1 Manager And A Bunch of Builders

How popular is Needs Staff - Arcane Wars?

Currently there is 0 online out of a possible 0. The number of votes this month is 1 since the 1st. Voting allows you to get rewards for free.

Most Recent Voters

Below are the five most recent players to vote for Needs Staff - Arcane Wars and recieved a reward.

Minecraft Player Username Score
Anonymous
Anonymous

Needs Staff - Arcane Wars

IP Address
arcanewars.serv.nu
Server Score
Status Offline
Recommended Version 1.16.5
Host Location United States
Rank 874
Players Online 0
Votes this Month 1
Total Votes 2
Website https://arcanewars.enjin.com/
Last Updated 3463 minutes ago
Join Date 2017-06-20 11:32:53
Game Modes Faction OP PVP Raiding Survival
Supported Versions 1.16.5 1.16.4 1.16.3

Best Minecraft Servers